Информатика, вопрос задал deva94 , 2 года назад

Помогите решить задачу Треугольник Паскаля
Даны два числа n и m. Создайте массив n×m и заполните его по следующим правилам: Числа, стоящие в строке 0 или в столбце 0 равны 1 (A[0][j] = 1, A[i][0] = 1). Для всех остальных элементов массива A[i][j] = A[i-1][j] + A[i][j-1], то есть каждый элемент равен сумме двух элементов, стоящих слева и сверху от него.

Входные данные: Вводятся два натуральных числа n и m, не превышающих 100.

Выходные данные: Выведите данный массив на экран. Примеры

Ввод 3 3

Вывод
1 1 1
1 2 3
1 3 6

Ответы на вопрос

Ответил mithridat
1

Ответ:

n, m = map(int, input().split())

A = [[1 for j in range(m)] for i in range(n)]

for i in range(1, n):

   for j in range(1, m):

       A[i][j] = A[i - 1][j] + A[i][j - 1]

for i in range(n):

   print(*A[i])


deva94: Спасибо!!
Новые вопросы