Информатика, вопрос задал Aurban1 , 1 год назад

Помогите решить задачу Python.

А вот и само задание :

Напишите программу которая будет определять возраст человека от года рождения человека, который он впишет в консоле


flash77779: Сделал

Ответы на вопрос

Ответил flash77779
1

import datetime

def get_age():

   birth_date = input("Enter your year of birth dd.mm.yyyy: ")

   birth_date = datetime.datetime.strptime(birth_date, "%d.%m.%Y")

   age = datetime.datetime.now() - birth_date

   return age.days // 365

print("You are {} years old".format(get_age()))

Приложения:

Aurban1: Можешь пожалуйста обьястнить как работает этот код?
flash77779: Добавил к ответу ещё одну картинку с коментариями кода
Aurban1: Спасибо!
flash77779: Всё понял?
flash77779: Разобрался со всем?
Новые вопросы