Помогите решить задачу по информатике в паскале!
Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере. Пробелы, знаки препинания, заглавные и строчные буквы важны!
Пример:
Ввод: 179
Вывод: The next number for the number 179 is 180.
The previous number for the number 179 is 178.
Ответы на вопрос
Ответил Аноним
0
var
x: real;
begin
read(x);
writeln('The next number for the number ', x, ' is ', x + 1);
writeln('The previous number for the number ', x, ' is ', x - 1);
end.
x: real;
begin
read(x);
writeln('The next number for the number ', x, ' is ', x + 1);
writeln('The previous number for the number ', x, ' is ', x - 1);
end.
Ответил HRAshton
0
var
y: real;
begin
read(y);
writeln(String.Format('The next number for the number {0} is {1}.', y, y + 1));
writeln(String.Format('The previous number for the number {0} is {1}.', y, y - 1));
end.
y: real;
begin
read(y);
writeln(String.Format('The next number for the number {0} is {1}.', y, y + 1));
writeln(String.Format('The previous number for the number {0} is {1}.', y, y - 1));
end.
Новые вопросы
Математика,
2 года назад
Обществознание,
10 лет назад
Физика,
10 лет назад
Математика,
10 лет назад
География,
10 лет назад