Помогите решить задачу о Паскалю
Дано четыре числа. Необходимо найти произведение тех чисел, которые находятся в диапазоне от 3 до 9 включительно. Формат входных данных С клавиатуры вводятся 4 целых числа, по модулю не превосходящих 20. Формат выходных данных Необходимо вывести единственное число — искомое произведение. Если чисел, удовлетворяющих условию, нет, выведите -1.
Ответы на вопрос
Ответил fefemf10
0
var n, k, i: integer;
begin k := 1; for i := 1 to 4 do begin read(n); if (n >= 3) and (n <= 9) then k := k * n; end; if k = 1 then writeln(-1) else writeln(k);end.
begin k := 1; for i := 1 to 4 do begin read(n); if (n >= 3) and (n <= 9) then k := k * n; end; if k = 1 then writeln(-1) else writeln(k);end.
Новые вопросы
Математика,
2 года назад
Литература,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Алгебра,
9 лет назад