Информатика, вопрос задал ilya666228 , 1 год назад

помогите решить задачу на языке Python





Анжела – очень занятая девушка, поэтому она старается не тратить много времени на шоппинг.

Однажды у нее закончился крем для лица, и она решила заказать себе первый попавшийся. Ну, почти...

"На своей красоте экономить нельзя", – подумала Анжела и решила купить первый попавшийся ей крем, который будет стоить X рублей или дороже.

Дан список цен на кремы. Необходимо определить цену крема, который заказала себе Анжела.

Формат входных данных
С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем, – цены на кремы. Каждое число вводится в отдельной строке.

В последней строке вводится целое число X – минимальная стоимость крема.Анжела – очень занятая девушка, поэтому она старается не тратить много времени на шоппинг.

Однажды у нее закончился крем для лица, и она решила заказать себе первый попавшийся. Ну, почти...

"На своей красоте экономить нельзя", – подумала Анжела и решила купить первый попавшийся ей крем, который будет стоить X рублей или дороже.

Дан список цен на кремы. Необходимо определить цену крема, который заказала себе Анжела.

Формат входных данных
С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем, – цены на кремы. Каждое число вводится в отдельной строке.

В последней строке вводится целое число X – минимальная стоимость крема.

Ответы на вопрос

Ответил daniil062
0

# вводим цены на кремы

prices = []

price = int(input())

while price != 0:

   prices.append(price)

   price = int(input())

# вводим минимальную стоимость крема

x = int(input())

# находим первый крем, стоимость которого больше или равна x

for price in prices:

   if price >= x:

       print(price)

       break

Новые вопросы