Помогите решить задачу на с++
Напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них. Числа — целые от 1 до 1000.
При решении задачи можно пользоваться только целочисленными арифметическими операциями +, -, *, //, %, =. Нельзя пользоваться нелинейными конструкциями: ветвлениями, циклами, функциями вычисления модуля, извлечения квадратного корня.
Примеры:
вход: 8 5
вывод: 8
вход : 5 8
вывод: 8
вход: 5 5
выход: 5
Ответы на вопрос
Ответил Giammy
0
#include <iostream>
int main()
{
int a, b;
std::cin >> a >> b;
std::cout << (a*(a / b) + b * (b / a)) / (b / a + a / b) << std::endl;
return 0;
}
Главное 0 не вводите :)
Ответил Giammy
0
Думаю можно и тернарным оператором воспользоваться, по-сути это не ветвление.
Новые вопросы
Русский язык,
2 года назад
Обществознание,
7 лет назад
Математика,
9 лет назад
Математика,
9 лет назад