Информатика, вопрос задал Тимоха2288 , 8 лет назад

Помогите решить задачу на Python!!!
Передавая записку на уроке английского языка, друзья не хотят, чтобы кто-то прочел ее содержимое. Для этого текст шифруют простым методом: заменяют каждую букву на букву, расположенную в алфавите на расстоянии N символов от исходной. Считается, что алфавит циклически замкнут. Напишите программу-шифровальщик.

Ответы на вопрос

Ответил BrightOne
0
'''
Шифр Цезаря.
Только для английского алфавита.
Python 3.X
'''


s = input('Строка для шифрования: ')
n = int(input('Сдвиг: '))
res = [] # список с символами результата
for l in s: # для каждого символа в строке
    if not 97 <= ord(l) <= 122: # если символ - не латинская буква ...
        res.append(l) # ... добавить к ответу "как есть"
    else:
        o = (ord(l) - 96 + n) % 26 # номер закод. буквы в алфавите
        char = chr(o + 96) # символ по таблице ASCII
        res.append(char) # добавить закодированную букву к ответу
print('Результат:', ''.join(res))
Ответил Аноним
0
Все же насколько современный Паскаль нагляднее и продуманнее разных там Питонов....
Новые вопросы