Информатика, вопрос задал 5xenr , 2 года назад

Помогите решить задачу на Питоне, Рекурсия

Задача
Напишите программу, содержащую рекурсивную функцию, которая по натуральному числу n, выводит все числа от n до 1. Основная программа должна содержать ввод исходных данных (число n) и вызов функции

Примеры
№ Входные данные Выходные данные
1 6 6 5 4 3 2 1
Запрещенные операторы: for;while;until

Ответы на вопрос

Ответил uplmtq
2

Ответ:

def allnumbers(n):

   if n == 0:

       return 1

   print(n, end=' ')

   allnumbers(n - 1)

n = int(input("Введите число n: "))

allnumbers(n)

Объяснение:

def allnumbers(n):  // Функция allnumbers, которая принимает аргумент n

   if n == 0:  // Если значение переменной n = 0

       return 1  // Выходим из функции

   print(n, end=' ')  // Выводим значение переменной n

   allnumbers(n - 1)  // Рекурсия

n = int(input("Введите число n: "))  // Вводим число n с клавиатуры

allnumbers(n) // Функция

Новые вопросы