Информатика, вопрос задал rumkeren , 7 лет назад

Помогите решить задачу на питоне. Нужно через массивы.
Числа Фибоначчи
F1 = F2 = 1, Fn = Fn-1 + Fn-2, при n > 2
Входные данные
В единственной строке входных данных записано натуральное число n (1≤n≤45).

Выходные данные
Вывести одно число Fn


lozromanik: На каком языке программирования?
rumkeren: на питоне

Ответы на вопрос

Ответил lozromanik
0

Відповідь:

Очень хороший код

def fibonacci_of(n):

   # Validate the value of n

   if not (isinstance(n, int) and n >= 0):

       raise ValueError(f'Positive integer number expected, got "{n}"')

   previous, fib_number = 0, 1

   for _ in range(2, n + 1):

       # Compute the next Fibonacci number, remember the previous one

       previous, fib_number = fib_number, previous + fib_number

   return fib_number

print(fibonacci_of(int(input())))

Пояснення:

Новые вопросы