Информатика, вопрос задал styles23 , 6 лет назад

Помогите решить задачу на питоне

Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одну строчку все элементы построенного массива, разделив их пробелами.

Примеры
входные данные
6
1 2 3 4 5 6
выходные данные
1 4

Ответы на вопрос

Ответил лекция
0

n = int(input())

A = list(map(int, input().split()))

B = []

for i in range(1, n - 1, 3):

   B.append(i)

print(*B)


styles23: Ошибка...
styles23: тест ввод ожидаемый получено
2 5 1 2 3 4 5 1 4
1 3 1 1
1
4
4
1 2 3 4
1 4
1
5
7
1 2 3 4 5 6 7
1 4 7
1 4
mathgenius: Одна строчка друзья:
mathgenius: print(' '.join(input().split(' ')[2::3]))
mathgenius: cрез это чудесная штука
mathgenius: Даже не нужен размер массива...
лекция: Киньте репорт на решение, неверное все же
Новые вопросы