Другие предметы, вопрос задал vasilisa020686 , 1 год назад

Помогите решить задачку, пожалуйста.
Напишите программу, которая запрашивает у пользователя два числа. Затем спросите их, хотели бы они сложить, вычесть, разделить или умножить эти числа. Выполните выбранную операцию с числами и покажите, какая операция выполняется. Напишите четыре функции, по одной для каждой математической операции.на языке python.

Ответы на вопрос

Ответил zertafel
1

Ответ:

Объяснение:

# Функция для сложения

def add(x, y):

   return x + y

# Функция для вычитания

def subtract(x, y):

   return x - y

# Функция для умножения

def multiply(x, y):

   return x * y

# Функция для деления

def divide(x, y):

   if y == 0:

       return "Ошибка: на ноль делить нельзя"

   return x / y

# Запрос у пользователя двух чисел

num1 = float(input("Введите первое число: "))

num2 = float(input("Введите второе число: "))

# Запрос у пользователя выбора операции

print("Выберите операцию:")

print("1. Сложение")

print("2. Вычитание")

print("3. Умножение")

print("4. Деление")

choice = input("Введите номер операции (1/2/3/4): ")

# Выполнение выбранной операции

if choice == '1':

   result = add(num1, num2)

   operation = "+"

elif choice == '2':

   result = subtract(num1, num2)

   operation = "-"

elif choice == '3':

   result = multiply(num1, num2)

   operation = "*"

elif choice == '4':

   result = divide(num1, num2)

   operation = "/"

print(f"Результат: {num1} {operation} {num2} = {result}")


vasilisa020686: Не работает
vasilisa020686: Я похожий код написала, у меня тоже не работает
vasilisa020686: Работает. Это у меня с отступами проблема. Спасибо огроменное
vasilisa020686: Спасибо. Всё работает.
Новые вопросы