Помогите решить задачи (VBA)
1. Написать программу вычисления стоимости поездки на автомобиле на дачу (туда и обратно). Исходными данными являются: расстояние до дачи (в километрах); количество бензина, которое потребляет автомобиль на 100 км пробега; цена одного литра бензина.
2. Написать программу пересчета веса из фунтов в килограммы (1 фунт равен 409,5 г).
3. Написать программу Конвертер величин: с клавиатуры вводиться вес информации в байтах. На выходе получаем перевод величины в:
• биты , килобайты, мегабайты, гигабайты
1байт = 8 бит
1Кб (килобайт) = 1024 байт
1Мб (мегабайт) = 1024 Кб
1Гб (гигабайт) = 1024 Мб
1Тб (терабайт) = 1024 Гб
Ответы на вопрос
Ответил 140201
0
program aaa;
var
s, b, l, c: real;
begin
writeln('введите s, b, l');
readln(s, b, l);
c := b / 100 * s * 2 * l;
writeln('стоимость поездки: ', c)
end.
program aaa;
{Написать программу пересчета веса из фунтов (f) в килограммы (kg)
(1 фунт равен 409,5 г).}
var
f,kg: real;
begin
writeln('введите f');
readln(f);
kg:=f*409.5/1000;
writeln(f,' фунтов = ', kg:8:3,' килограмм')
end.
program aaa;
{Написать программу Конвертер величин:
с клавиатуры вводиться вес информации в байтах (b).
На выходе получаем перевод величины в: биты (bi) , килобайты (kb),
Мегабайты (mb), гигабайты (gb).
1байт = 8 бит
1Кб (килобайт) = 1024 байт
1Мб (мегабайт) = 1024 Кб
1Гб (гигабайт) = 1024 Мб
1Тб (терабайт) = 1024 Гб}
var
b,bi,kb: real; mb,gb,tb: decimal;
begin
writeln('введите b');
readln(b);
bi:=b*8;
kb:=b/1024;
mb:=kb/1024;
gb:=mb/1024;
tb:=gb/1024;
writeln(b,' байт = ', bi,' бит');
writeln(b,' байт = ', kb,' килобайт');
writeln(b,' байт = ', mb,' мегабайт');
writeln(b,' байт = ', gb,' гигабайт');
writeln(b,' байт = ', tb,' терабайт')
end.
//формат вывода (к-во знаков ...) определите сами
var
s, b, l, c: real;
begin
writeln('введите s, b, l');
readln(s, b, l);
c := b / 100 * s * 2 * l;
writeln('стоимость поездки: ', c)
end.
program aaa;
{Написать программу пересчета веса из фунтов (f) в килограммы (kg)
(1 фунт равен 409,5 г).}
var
f,kg: real;
begin
writeln('введите f');
readln(f);
kg:=f*409.5/1000;
writeln(f,' фунтов = ', kg:8:3,' килограмм')
end.
program aaa;
{Написать программу Конвертер величин:
с клавиатуры вводиться вес информации в байтах (b).
На выходе получаем перевод величины в: биты (bi) , килобайты (kb),
Мегабайты (mb), гигабайты (gb).
1байт = 8 бит
1Кб (килобайт) = 1024 байт
1Мб (мегабайт) = 1024 Кб
1Гб (гигабайт) = 1024 Мб
1Тб (терабайт) = 1024 Гб}
var
b,bi,kb: real; mb,gb,tb: decimal;
begin
writeln('введите b');
readln(b);
bi:=b*8;
kb:=b/1024;
mb:=kb/1024;
gb:=mb/1024;
tb:=gb/1024;
writeln(b,' байт = ', bi,' бит');
writeln(b,' байт = ', kb,' килобайт');
writeln(b,' байт = ', mb,' мегабайт');
writeln(b,' байт = ', gb,' гигабайт');
writeln(b,' байт = ', tb,' терабайт')
end.
//формат вывода (к-во знаков ...) определите сами
Ответил 140201
0
ой, да. сорри. не обратила внимания на язык
Ответил Mashenka3004
0
Но всё равно спасибо)
Новые вопросы