Помогите решить задачи в Pascal,пожалуйста!
Задачи
1. Вычислите периметр прямоугольника. Значения сторон прямоугольника пользователь вводит с клавиатуры.
2. Дано целое число (пользователь вводит с клавиатуры). Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 6; если нулевым, то заменить его на 16. Вывести полученное число.
Выберите правильную программy:
А
Б
В
3. Написать программу (по аналогии, задача 2) .
Дано целое число. Если оно является положительным, то умножить его на 5; если отрицательное, возвести его в квадрат; если нулевым, то заменить его на 15. Вывести полученное число.
4.Вывести наибольшее число из двух чисел. Два числа вводит пользователь с клавиатуры.
Ответы на вопрос
Ответил wensent
2
Ответ:
1
var a,b,p:integer;
begin
writeln('Введите длину');
readln(a);
writeln('Введите ширину');
readln(b);
writeln('Периметр прямоугольника = ',2*(a+b),' см')
end.
2
var a:integer;
begin
writeln('Введите число');
readln(a);
if a > 0 then a:= a + 1;
if a < 0 then a:= a - 6;
if a = 0 then a:= 16;
writeln(a);
end.
3
var a:integer;
begin
writeln('Введите число');
readln(a);
if a > 0 then a:= a * 5;
if a < 0 then a:= a * a;
if a = 0 then a:= 15;
writeln(a);
end.
4
var a,b:integer;
begin
writeln('Введите 1 число');
readln(a);
writeln('Введите 2 число');
readln(b);
if a > b then writeln(a)
else
writeln(b);
end.
zhenyanabokova123:
СПАСИБО
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Алгебра,
2 года назад
Литература,
2 года назад
Биология,
8 лет назад