Помогите решить задачи на составление программы линейной структуры с переменной:
1. Заработок рабочих на фабрике составил 624750 руб. Его нужно разделить поровну между а рабочих и k служащих. Выведите заработок каждого работника.
2. Мальчик может бегать в 3 раза быстрее, чем ходить. Скорость его ходьбы равна y км/ч. Он принял участие в марафонском забеге, но сошел с дистанции, пробежав только x км. Сколько времени он затратил на преодоление этого расстояния.
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!
№1
begin
var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
Writeln('Заработок работника равен ',624750/(a+k))
end.
Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750
№2
begin
var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
var x:=ReadReal('Мальчик пробежал, км: ');
Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.
Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км: 12
Затрачено времени на бег, ч: 0.77
// Внимание! Если программа не работает, обновите версию!
№1
begin
var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
Writeln('Заработок работника равен ',624750/(a+k))
end.
Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750
№2
begin
var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
var x:=ReadReal('Мальчик пробежал, км: ');
Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.
Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км: 12
Затрачено времени на бег, ч: 0.77
Новые вопросы
Английский язык,
2 года назад
Українська мова,
2 года назад
Биология,
8 лет назад
Физика,
8 лет назад