Информатика, вопрос задал tumanovivan , 1 год назад

Помогите решить задачи на Python
1) Написать программу, позволяющую пользователю ввести текст. Слова в тексте разделены одним или несколькими пробелами, или переносом строки. Программа должна вывести на экран количество повторений для каждого слова в этом тексте. Используйте словарь.
2) Написать программу, позволяющую пользователю ввести код активации. Программа должна проверить, был ли этот код использован ранее. Если код уже использовался - вывести строку “Данный код уже был использован”, “Продукт активирован” - иначе. Необходимо использовать множества.
3) Написать программу, позволяющую пользователю вводить целые числа до тех пор, пока не будет введено значение 0. Необходимо определить, сколько пользователь ввел уникальных чисел и вывести результат на экран. Используйте множество.


p15: совет - делите по одной

Ответы на вопрос

Ответил pisarkovoleksij
4

Ответ:

1)python

text = input("Введите текст: ")

words = text.split() # разбиваем текст на слова

word_count = {} # создаем пустой словарь для хранения количества повторений слов

for word in words:

    if word in word_count: # если слово уже есть в словаре, увеличиваем его количество на 1

        word_count[word] += 1

    else: # если слова нет в словаре, добавляем его и устанавливаем количество равным 1

        word_count[word] = 1

# выводим результаты

for word, count in word_count.items():

    print(word, ":", count)

2)python

used_codes = set() # создаем пустое множество для хранения использованных кодов

code = input("Введите код активации: ")

if code in used_codes: # если код уже использовался, выводим сообщение об ошибке

    print("Данный код уже был использован")

else: # если код еще не использовался, добавляем его в множество и выводим сообщение об успешной активации

    used_codes.add(code)

    print("Продукт активирован")

3) python

unique_numbers = set() # создаем пустое множество для хранения уникальных чисел

while True:

    num = int(input("Введите число (для выхода введите 0): "))

    if num == 0: # если пользователь ввел 0, выходим из цикла

        break

    unique_numbers.add(num) # добавляем число в множество уникальных чисел

print("Вы ввели", len(unique_numbers), "уникальных чисел")

Новые вопросы