Информатика, вопрос задал superartem1234566 , 7 лет назад

Помогите решить! Составьте программу, которая запрашивает число. Если введено положительное число, то на экран выводится квадрат этого числа. В противном случае выводится сообщение "Ошибка. Введено неправильное число" и повторный запрос на ввод нового числа.

Ответы на вопрос

Ответил vimmortal2
1

Программа:

Python:

while True:

   n = int(input('Введите число: '))

   if n > 0:

       print(n * n)

       break

   else:

       print('Ошибка. Введено неправильное число')

Pascal:

var

 n: integer;

begin

 while True do begin

   write('n = '); readln(n);

   if n > 0 then begin

     writeln(n * n);

     break

   end

   else writeln('Ошибка. Введено неправильное число');

 end;

end.

Новые вопросы