Помогите решить . Составьте программу формирования и вывода на экран одномерного массива ,состоящего из элементов главной диагонали двумерного массива ,заданного с помощью датчика случайных чисел.(Паскаль абс) С объяснением .
Ответы на вопрос
Ответил DanayDemenir
0
const
n=5
var
a:array[1..n] of integer; //создали одномерный массив длинной 5
b:array[1..n,1..n] of integer; //создали двумерный массив 5х5
i,j:integer; //i,j- счетчик
begin
for i:=1 to n do
for j:=1 to n do
b[i,j]:=random(10)+1; {задали массив случайными числами в диапазоне от 1 до 10}
for i:=1 to n do
begin
a[i]:=b[i,i]; //присваиваем i-ому элементу массива элемент i-i.
end; //То есть 1-ому, 1-1, 2-ому 2-2. Это и есть главная диагональ.
{вывод двумерного массива на всякий случай:
for i:=1 to n do
begin
for j:=1 to n do
begin
write(b[i,j],' ');
end;
writeln("");
end; }
For i:=1 to n do
write(a[i]," ");
readln();
end.
n=5
var
a:array[1..n] of integer; //создали одномерный массив длинной 5
b:array[1..n,1..n] of integer; //создали двумерный массив 5х5
i,j:integer; //i,j- счетчик
begin
for i:=1 to n do
for j:=1 to n do
b[i,j]:=random(10)+1; {задали массив случайными числами в диапазоне от 1 до 10}
for i:=1 to n do
begin
a[i]:=b[i,i]; //присваиваем i-ому элементу массива элемент i-i.
end; //То есть 1-ому, 1-1, 2-ому 2-2. Это и есть главная диагональ.
{вывод двумерного массива на всякий случай:
for i:=1 to n do
begin
for j:=1 to n do
begin
write(b[i,j],' ');
end;
writeln("");
end; }
For i:=1 to n do
write(a[i]," ");
readln();
end.
Новые вопросы