Информатика, вопрос задал lyudmilaloktev , 9 лет назад

Помогите решить!
Составить программу вычисления значений функции F(x) на отрезке [a,b] с шагом h. Результат первое значение аргумента второе- соответствующая значению функция.
записать в паскале (не через массив)
Задание 1. номер 9

Приложения:

Ответы на вопрос

Ответил Аноним
0
var
  a, b, h, x: real;
  i, n: integer;

begin
  writeln('Введите границы интервала (a,b)и шаг табуляции h:');
  readln(a, b, h);
  n := Trunc((b - a) / h) + 1;
  writeln('    x          F(x)');
  for i := 1 to n do
  begin
    x := a + h * (i - 1);
    writeln(x:9:6, '  ', 2 * tan(x / 2) + 1:9:6)
  end
end.

Тестовое решение:

Введите границы интервала (a,b)и шаг табуляции h:
-2 3 0.25
    x          F(x)
-2.000000  -2.114815
-1.750000  -1.394843
-1.500000  -0.863193
-1.250000  -0.442969
-1.000000  -0.092605
-0.750000   0.212747
-0.500000   0.489316
-0.250000   0.748690
 0.000000   1.000000
 0.250000   1.251310
 0.500000   1.510684
 0.750000   1.787253
 1.000000   2.092605
 1.250000   2.442969
 1.500000   2.863193
 1.750000   3.394843
 2.000000   4.114815
 2.250000   5.185143
 2.500000   7.019139
 2.750000  11.083831
 3.000000  29.202840



Ответил mstexno
0
3 у нас задают задания с университетов, если их решат то пусть будет, если нет сами удалятся. Пока что мы не планируем ничего добавлять или изменять в предметах или уровнях образования
Ответил Аноним
0
var
   a,b,h,x,f:real;
begin
write('Введите a,b,h: ');
readln(a,b,h);
x:=a;
writeln('x':8,'F(x)':12);
repeat
  f:=tan(x/2)+2*cos(x);
  writeln(x:10:3,f:10:3);
  x:=x+h;
  until x>b;
end.
Приложения:
Новые вопросы