Помогите решить, пожалуйста!
Даны значения массива {ai}, i=0,...,10 и переменной х. составьте программу вычисления алгебраического многочлена 10-й степени по формуле Горнера:
а10х в 10 степени+а9хв 10 степени+...+а1х+а0=((...(а10х+а9)х+а8)х+...+а1)х+а0.
Ответы на вопрос
Ответил Aillianna
0
const
handsfree = false;
nmax = 10;
random_min = -50;
random_max = 50;
var
a: array[0..nmax] of real;
i, n: integer;
sum, x: real;
begin
{ввод массива}
n := nmax;
if handsfree then begin
for i := 0 to n do
begin
a[i] := random(random_max - random_min) + random_min;
write(a[i], ' ');
end
end
else begin
for i := 0 to n do
readln(a[i]);
end;
writeln();
{подсчет суммы}
write('x = ');
readln(x);
sum := a[n];
for i := n - 1 downto 0 do
sum := sum * x + a[i];
writeln('S = ', sqrt(sum));
end.
Новые вопросы