Информатика, вопрос задал ZZerefF , 9 лет назад

Помогите решить 2 задачи в паскале:
1)Определить равны ли все цифры заданного пятизначного числа.
2)Каждое число Фибоначчи вычисляется как f1=0, f2=1, а начиная с третьего по формуле fn=fn-1+fn-2. Составить программу, которая вычисляет n чисел Фибоначчи.

Ответы на вопрос

Ответил APALoff
0
1.
Function Check(A : Longint) : Boolean;
Begin
 If A>9 then Check:=((A mod 10)=(A div 10 mod 10)) and Check(A div 10) else Check:=True;
end;
Var N : Longint;
Begin
  Readln(N);
  Writeln(Check(N));
end.
Ответил APALoff
0
Function GetNFib(nn : Longint) : Longint;
Function GetNFibonanchi(a,b,n : Longint) : Longint;
Begin
If n>3 then GetNFibonanchi:=GetNFibonanchi(a+b,a,n-1)
else GetNFibonanchi:=a+b;
End;
Begin
If nn<1 then GetNFib:=0
else GetNFib:=GetNFibonanchi(1,0,nn+1);
End;

Begin { 1, 1, 2, 3, 5, 8, 13, 21, 34, 55, 89, 144, 233 }
Writeln(GetNFib(7));
End.
Новые вопросы