Информатика, вопрос задал klorman , 9 лет назад

ПОМОГИТЕ ПЖ РЕШИТЬ ЗАДАЧУ ПО ИНФЕ НА Python!!!
55 балов.


В списке все элементы различны. Поменяйте местами минимальный и максимальный элемент этого списка.

Входные данные
Вводится список чисел. Все числа списка находятся на одной строке.

Выходные данные
Выведите ответ на задачу.

Примеры
входные данные
3 4 5 2 1
выходные данные
3 4 1 2 5

Ответы на вопрос

Ответил Аноним
0
lst=input("Введите ряд натуральных чисел: ").split()
for i in range(len(lst)):
    lst[i]=int(lst[i])
mx=max(lst)
mn=min(lst)
imx=lst.index(mx)
imn=lst.index(mn)
lst[imx]=mn
lst[imn]=mx
for i in lst:
    print(i,end=" ")

Тестовое решение:
Python 3.4.2 (v3.4.2:ab2c023a9432, Oct  6 2014, 22:15:05) [MSC v.1600 32 bit (Intel)] on win32
Type "copyright", "credits" or "license()" for more information.
>>> ================================ RESTART ================================
>>>
Введите ряд натуральных чисел: 3 4 5 2 1
3 4 1 2 5
>>>
Ответил klorman
0
спс
Новые вопросы