Информатика, вопрос задал kanekoaoy , 6 лет назад

Помогите пж, программа IDLE(Python) Решить задачи с помощью цикла while
1. Вывести повторяющуюся строчку из любой песни 25 раз.
2.Написать программу которая получает два целых числа А и В (0<А<В) и выводит квадраты всех натуральных чисел в интервале от А до В


olegkrasnov98: Точно с помощью цикла while? Задание больше на цикл for
kanekoaoy: да

Ответы на вопрос

Ответил olegkrasnov98
1

1.

counter = 1    # счётчик

s = input()    # ввод строки, которую нужно повторить

while counter != 25:    # цикл, выводящий текст

   print(s)

   counter += 1

2.

A, B = int(input()), int(input())

counter = A

while counter <= B:

   print(counter**2)

   counter += 1

P.S.: Через цикл for это было бы проще :)


kanekoaoy: от души
Новые вопросы