Информатика, вопрос задал asteba , 8 лет назад

Помогите пж
Напишите программу,которая в последовательности натуральных чисел определяет количество двузначных чисел,кратных 8. Программа получает на вход натуральные числа,количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0(0 - признак окончания ввода,не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: количество двузначных чисел,кратных 8.

Ответы на вопрос

Ответил Аноним
0
Решение из разряда "в одну строчку".

// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Write(ReadSeqIntegerWhile(k->k>0).Where(k->(k in [10..99]) and (k mod 8=0)).Count)
end.

Ответил asteba
0
Прости,я забыл отметить,что задачу нужно решить циклом с постусловием,то,что ты написал,я ещё не проходил) (9 класс)
Ответил Аноним
0
Ваша "забывчивость" - это Ваша проблема. Учитесь за свои действия отвечать.
Новые вопросы