Информатика, вопрос задал karinakarinochka2020 , 7 лет назад

Помогите пж
Написать программу на Python
Напишите программу, которая в последовательности целых чисел определяет их сумму и подсчитывает разность количества положительных и отрицательных чисел последовательности. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). программа должна вывести два числа: сумму чисел и разность количества положительных и отрицательных чисел.

Ответы на вопрос

Ответил raf1O5
0

sum = 0

pCount = 0

oCount = 0

print('Вводите числа по очереди')

print('Чтобы закончить введите 0')

while True:

   n = int(input())

   if n == 0:

       break

   sum += n

   if n > 0:

       pCount += 1

   else:

       oCount += 1

po = pCount - oCount

print('Сумма чисел:',sum)

print('Разность количества положительных и отрицательных:',po)

Новые вопросы