Информатика, вопрос задал ainurashatovna043034 , 2 года назад

помогите пж.мне нужно написать программу которая будет задавать вопросы и та выдавать ответы,если ответ правильный то "правильно" если неправильный "неверныйответ" . И показывает количество правильных и неправильных ответов​
PYTHON

Ответы на вопрос

Ответил jhonfedotov
0

Какие собственно вопросы, может как-то конкретнее опишите задание ?

Если так-то, то вы выдаёте вопрос на консоль, с вариантами ответа да/нет, с помощью оператора if, добавляете 1 к правильным или не правильным ответам( по желаю делаете проверку, если значение не является ни да, ни нет (else))


ainurashatovna043034: с помощью словаря,там должен быть вопрос:ответ
Ответил wherethefux
0

import random

print("Привет, давай поиграем в игру!")

print("Я задам тебе несколько вопросов и ты должен ответить на них.")

print("Если ответ правильный, то я скажу 'Правильно!'.")

print("Если ответ неправильный, то я скажу 'Неверный ответ'.")

print("Готов? Начнем!")

print()

correct = 0

incorrect = 0

for i in range(5):

   num1 = random.randint(1, 10)

   num2 = random.randint(1, 10)

   answer = int(input("Сколько будет " + str(num1) + " + " + str(num2) + "? "))

   if answer == num1 + num2:

       print("Правильно!")

       correct += 1

   else:

       print("Неверный ответ.")

       incorrect += 1

print()

print("Правильных ответов:", correct)

print("Неправильных ответов:", incorrect)

print("Прощай!")

Новые вопросы