Информатика, вопрос задал dedmorozik1 , 6 лет назад

Помогите пж!!!

Это работа в Питоне (Python)

1) Постройте и запишите в виде программы алгоритм вычисления суммы квадратов 10 произвольных чисел, вводимых с клавиатуры в процессе выполнения программы.

Следующее задание

2) Напишите программу вычисления количества цифр в заданном натуральном числе.

Еще одно задание

3) Напишите программу вычисления суммы чисел, введенных с клавиатуры, пока сумма не превысит 1000.


dedmorozik1: Дайте ответ пж

Ответы на вопрос

Ответил Rediska873
2

#1

sum = 0

for i in range(10):

   num = int(input())

   sum += num**2

print(sum)

#########

#2

num = int(input())

lenth = len(str(num))

print(lenth)

#########

#3

num = int(input())

sum = 0

while sum + num <= 1000:

   sum += num

   num = int(input())

print(sum)

#########

Приложения:

dedmorozik1: Спасибо, пойду проверять
dedmorozik1: Там выдает ошибку, что неправильный синтаксис
dedmorozik1: bash: syntax error near unexpected token
dedmorozik1: Ты в какой версии работал?
dedmorozik1: ща скачаю
dedmorozik1: Хз, не работает
dedmorozik1: ты можешь мне скрины прислать
dedmorozik1: спасиибо
Новые вопросы