Информатика, вопрос задал idontknowhowtodothis , 7 лет назад

Помогите пж дополнить программу в паскале так, чтобы в введенном предложении пропадала не только русская буква "о", но и "О".
Само задание, которое нужно было выполнить: Составить программу на Паскале, которая удалит все буквы «о» из текста, который состоит из 6 слов.
Мой ответ:
var
a:string;
i:integer;
begin
writeln('Введите предложение из 6 слов');
readln(a);
for i:= 1 to 6 do
if a[i] = 'о' then
delete(a,i,1);
writeln(a);
end
В чем ошибка и что нужно добавить? Помогите!!! Даю 58 баллов!

Ответы на вопрос

Ответил ldglkva
1

Ответ:

Переменной целого типа  k присвоим значение, равное длине введенной строки (количество символов в строке).  

k:= Length(a);

var

a: string;

i,k: integer;

begin

writeln('Введите предложение из 6 слов');

readln(a);

k:= Length(a);    

for i := k downto 1 do

if (a[i]='О') or (a[i]='о') then

delete(a,i,1);

writeln(a);

end.

Можно еще так.

var

a: string;

i,k: integer;

begin

writeln('Введите предложение из 6 слов');

readln(a);

a:=a.Replace('о','');

a:=a.Replace('О','');

writeln(a);

end.


MrSolution: Неверный код. Если ввести, например, предложение со словом зоообъединение, то программа преобразует это слово в зобъединение.
Новые вопросы