Информатика, вопрос задал nyamychnyap6gpag , 7 лет назад

ПОМОГИТЕ! ПРОШУУУ!! ДАЮ 33 БАЛЛА
Написать программу на языке PASCAL, которая в массиве размером 30 со случайными числами ищет нечетные числа и выводит на экран их кол-во.

Ответы на вопрос

Ответил dimkadim501
0

program answer;

uses CRT;

Var  

a: array [1..30] of integer;

i: integer; n:integer;

begin

clrscr;

for i:=1 to 30 do begin

a[i]:= random(100);

writeln (a[i]);

end;

Writeln ('chetnie chisla s massiva: ');

   for i:=1 to 30 do

       begin

       if ((a[i]) mod 2 = 0) then writeln (a[i])

       end;

end.

Ответил BobbyFresnel
0

// PascalABC.NET

begin

 var a := ArrRandom(30, -99, 99);

 a.Println.Count(p -> p.IsOdd).Print

end.

Приложения:
Новые вопросы