Информатика, вопрос задал MaksimDavidov22 , 7 лет назад

Помогите прошу!!!
Написать программу на языке Pascal для решения задачи:
а) Ввести случайным образом (возможные значения от 0 до 60) значения 7 элементов массива, содержащего целые числа. Значение каждого элемента массива уменьшить на 10. Вывести значения элементов измененного массива на экран в строчку (через пробел).
б) Ввести с клавиатуры значения 15 элементов массива, содержащего вещественные числа. Значение каждого элемента массива увеличить в 4 раза. Вывести значения элементов измененного массива на экран в столбик.

Ответы на вопрос

Ответил Puz1koO
3

1)

var

 a:array [1..7] of integer;

 i:integer;

begin

 for i:=1 to 7 do  

   begin

     a[i]:=random(61);

     write(a[i],' ');

     a[i]:=a[i]-10;

   end;

 for i:=1 to 7 do

   write(a[i],' ');

end.

2)

const

 n=15;

var

 a: array [1..n] of real;

 i:integer;

begin

 for i:=1 to n do

   readln(a[i]);

 for i:=1 to n do

   begin

     a[i]:=a[i]*4;

     write(a[i],' ');

   end;

end.


MaksimDavidov22: боже , счастливой тебе жизни добрый человек !!!
Puz1koO: Она будет счастливее, если вы ответите мой ответ как лучший) Спасибо
MaksimDavidov22: а сейчас, я не знал просто!
Новые вопросы