Информатика, вопрос задал kuleshovgenya , 9 лет назад

ПОМОГИТЕ! Программу через Паскаль
Планы по благоустройству города иногда имеют свойство воплощаться в жизнь. Вот, к примеру, раньше Кеше, чтобы добраться до бассейна, приходилось переходить одну широкую дорогу. А теперь наземного перехода больше нет, зато есть подземный переход. Правда, расстояние, которое приходится преодолевать по подземному переходу, в несколько раз больше, чем было по наземному. Но есть и плюсы — бывает, начинает накрапывать дождь, а пока спустишься в переход, пройдёшь его, поднимешься — а дождь уже успел превратиться в ливень, пролиться, и выглянувшее солнце сушит лужи.

Маршрут Кеши от дома до бассейна выглядит следующим образом. Сначала Кеша идёт по улице в течение d минут, потом идёт по подземному переходу в течение w минут, после чего вновь идёт по улице в течение p минут.

Известно, что, пока Кеша шёл в бассейн, прошёл дождь длительностью u минут. Дождь начался не ранее момента, в который Кеша вышел из дома, и закончился не позднее того момента, когда Кеша дошёл до бассейна. Ваша задача — определить, какое максимальное и какое минимальное время Кеша мог идти под дождём.
Входные данные

В первой строке содержатся целые числа d, w, p, u (1 ≤ d, w, p ≤ 1000,  u ≤ d + w + p), описанные в условии задачи.
Выходные данные

Выведите два целых числа — максимальное и минимальное время, которое Кеша мог идти под дождём.
Пример
Входные данные

14 10 8 15

Выходные данные

14 5

Ответы на вопрос

Ответил terorrik123
0
var  d, w, p, u: integer;
begin  read(d);  read(w);  read(p);  read(u);  if u <= d + w then  begin    write(d, ' ');    write(u - w);  end  else if u > d + w + p then  begin    write(p + d,' ');    write(p + d);  end  else   begin    write(u - w,' ');    write(p);  end;end.
Новые вопросы