Помогите програмку сделать Надо написать программу которая определяет принадлежность точки с координатами x,y в заштрихованной области
Приложения:

Ответы на вопрос
Ответил нуржан2
0
Program shtrihi;
uses crt;
var
x,y: real;
begin
writeln('Введите координаты точки:');
write('X='); readln(x);
write('Y='); readln(y);
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
if (y>=0) and (y>=-x+2) and (x*x+y*y<=9) and (y<=exp((1/2)*ln(abs(x)))) then
begin
writeln('Точка (',x,',',y,') попадает в заштрихованную область ');
end
else
writeln('Точка (',x,',',y,') HE попадает в заштрихованную область ');
end.
uses crt;
var
x,y: real;
begin
writeln('Введите координаты точки:');
write('X='); readln(x);
write('Y='); readln(y);
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
if (y>=0) and (y>=-x+2) and (x*x+y*y<=9) and (y<=exp((1/2)*ln(abs(x)))) then
begin
writeln('Точка (',x,',',y,') попадает в заштрихованную область ');
end
else
writeln('Точка (',x,',',y,') HE попадает в заштрихованную область ');
end.
Новые вопросы