Информатика, вопрос задал jekaklyk15 , 1 год назад

Помогите пожайлуста с заданием по информатике в Pascal
Написать программу
Задание
выдать последнюю цифру квадрата натурального числа от 1 до 9

Ответы на вопрос

Ответил alchetorn
0

Ответ:

Не совсем поняла, как именно задаётся число: с клавиатуры или через цикл.

Если число задаётся с клавиатуры:
program ex1;

var n:byte;

begin

readln(n);

writeln(sqr(n) mod 10);

end.

Если нужно последовательно вывести последние цифры квадратов чисел от 1 до 9:

program ex2;

var i:byte;

begin

for i:=1 to 9 do write(sqr(i) mod 10, ' ');

end.

Новые вопросы