Информатика, вопрос задал ponchik189 , 10 лет назад

Помогите пожалуйста задачу сделать в паскале.

Составьте программу, которая удаляет из слова X те буквы, которые встречаются в слове Z. Слова X и Z вводятся с клавиатуры.

Ответы на вопрос

Ответил Soqwa
0
var
x,z:string;
i:integer;
ar:array['а'..'я'] of boolean;
begin
readln(x);
readln(z);

for i:=1 to Length(z) do
  ar[z[i]]:=true;
  for i:=Length(x) downto 1 do
    if (ar[x[i]] = true) then delete(x,i-1,1);   
writeln(x);
end.

Не забудь отметить лучший ответ ;-)
Новые вопросы