Помогите пожалуйста!! Задача по паскалю!
введите три числа a, b, с. определите количество положительных чисел в данном наборе
Ответы на вопрос
Ответил Аноним
0
var
a, b, c: real;
n: integer;
begin
Write('Введите через пробел три числа: ');
Readln(a, b, c);
if a > 0 then n := 1 else n := 0;
if b > 0 then n := n + 1;
if c > 0 then n := n + 1;
Writeln('Положительных чисел- ', n)
end.
Тестовое решение:
Введите через пробел три числа: -3.54 2.16 4
Положительных чисел- 2
a, b, c: real;
n: integer;
begin
Write('Введите через пробел три числа: ');
Readln(a, b, c);
if a > 0 then n := 1 else n := 0;
if b > 0 then n := n + 1;
if c > 0 then n := n + 1;
Writeln('Положительных чисел- ', n)
end.
Тестовое решение:
Введите через пробел три числа: -3.54 2.16 4
Положительных чисел- 2
Новые вопросы
Физика,
2 года назад
Геометрия,
2 года назад
Химия,
9 лет назад
Математика,
9 лет назад
Биология,
10 лет назад