Помогите пожалуйста. Задача написать программу на паскале и к ней блок схем объясняющий её, с пояснениями. "Найти Сумму и произведение элементов одномерного массива. В массиве 20 чисел"
Ответы на вопрос
Ответил Аноним
0
Вот программа:
Var
A:array[1..20] of real;
i:integer;
S,P:real;
Begin
S:=0;
P:=1;
WriteLn('Введите 20 чисел:');
For i:= 1 to 20 do
Begin
Read(A[i]);
S:=S+A[i];
P:=P*A[i];
End;
WriteLn('S = ',S);
WriteLn('P = ',P);
End.
Вот блок-схема:
Var
A:array[1..20] of real;
i:integer;
S,P:real;
Begin
S:=0;
P:=1;
WriteLn('Введите 20 чисел:');
For i:= 1 to 20 do
Begin
Read(A[i]);
S:=S+A[i];
P:=P*A[i];
End;
WriteLn('S = ',S);
WriteLn('P = ',P);
End.
Вот блок-схема:
Приложения:

Ответил Аноним
0
Готово))
Новые вопросы