Информатика, вопрос задал Milaya778 , 8 лет назад

ПОМОГИТЕ ПОЖАЛУЙСТА !!!Задача 1
Составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 10 до 30 и находит сумму элементов с чётными значениями количество элементов с нечётными значениями
Задача 2
Составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с чётными значениями

Ответы на вопрос

Ответил jerrystreet
0
1)
program n_1;
var a:array[1..10] of integer;
i, n, k, s:integer;
begin
writeln('Введите кол-во элементов');
readln(n);
k:=0;
for i:=1 to n do
begin
a[i]:=random(20)+10;
writeln(a[i],' ');
if (i mod 2=0) then
s:=s+a[i];
If (i mod 2<>0) then
k:=k+1;
end;
writeln('Сумма=',s);
writeln('Кол-во нечётных элементов=',k);
end.
2)
program kol_vo_elementov;
var a:array[1..10] of integer;
i, n, k, s:integer;
begin
writeln('Введите кол-во элементов');
readln(n);
k:=0;
for i:=1 to n do
begin
a[i]:=random(9)+1;
writeln(a[i],' ');
if (i mod 2=0) then
k:=k+1;
end;
writeln('Кол-во чётных элементов=',k);
end.

Новые вопросы