Информатика, вопрос задал sharumas , 2 года назад

Помогите ,пожалуйста , в с++
Написать программу, которая преобразует введенное с клавиатуры двухразрядное шестнадцатеричное число в десятичное.

Ответы на вопрос

Ответил Siaroza
2
Смотри вложения ->>>

Будут вопросы - обращайся!
Приложения:
Ответил nelle987
1
Выбирайте любое решение на ваш вкус, первое немного более топорное. 
Решение 1
.

#include <iostream>
#include <string>

int main() {
   const std::string numbers = "0123456789ABCDEF";
   std::string hex = "";

   int dec = 0;

   std::cin >> hex;

   for(int i = 0; i < hex.length(); i++)

      dec = 16 * dec + numbers.find(hex[i]);

   std::cout << dec;

   return 0;
}

Решение 2.
#include <iostream>

int main() {
   int num = 0;

   std::cin >> std::hex >> num;

   std::cout << num;

   return 0;
}
Новые вопросы