Информатика, вопрос задал ВиточкаТ , 2 года назад

Помогите, пожалуйста, в Паскале. Составить программу, по которой компьютер находит произведение нечетных чисел, начиная с единицы, и до тех пор, пока на вопрос, задаваемый после каждого шага вычислений: «Продолжить вычисления? (Д/Н)», отвечают ‘Д’.

Ответы на вопрос

Ответил Alexvsalex
4
var  a:longint;  b:integer;  s:string;  
begin 
 readln(s); 
 a:=1;  b:=1; 
 repeat   
  writeln('Продолжить вычисления? (Д/Н)');   
  b:=b+2;   
  a:=a*b;   
  readln(s); 
 until (s<>'Д'); 
 write(a);
end.
Новые вопросы