Помогите пожалуйста в информатикой!
Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех двузначных чисел, кратных 8. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0
(0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают
30 000.
Программа должна вывести одно число: сумму всех двузначных чисел, кратных 8.
Ответы на вопрос
Ответил petyaGavrikov
0
var a,s:integer;
begin
read(a);
while a<>0 do
begin
if (a>=10)and(a<=99)and(a mod 8 = 0) then s:=s+a;
read(a);
end;
writeln(s);
end.
Пример:
123 16 468 87 12 88 536 0
104
begin
read(a);
while a<>0 do
begin
if (a>=10)and(a<=99)and(a mod 8 = 0) then s:=s+a;
read(a);
end;
writeln(s);
end.
Пример:
123 16 468 87 12 88 536 0
104
Новые вопросы
Биология,
2 года назад
Окружающий мир,
2 года назад
Литература,
9 лет назад
Математика,
9 лет назад
Алгебра,
10 лет назад