Помогите пожалуйста!!Умоляю! Нужно написать программу на языке паскаль
Дан массив из 10 целых чисел. Определить, что больше: среднее арифметическое максимального и минимального элементов, или среднее арифметическое всех элементов массива.
Ответы на вопрос
Ответил APALoff
0
Var m : array[1..10] of Integer;
max,min,sum,i : Integer;
Begin
min:=1; max:=1; sum:=0;
For i:=1 to 10 do
Begin
m[i]:=Random(100);
sum:=sum+m[i];
If m[i]<m[min] then min:=i;
If m[i]>m[max] then max:=i;
Writeln(m[i]);
end;
Writeln('Ср.арифм. макс.и мин. элементов: ', (m[max]+m[min])/2);
Writeln('Ср.арифм. всех элементов: ', sum/10);
end.
max,min,sum,i : Integer;
Begin
min:=1; max:=1; sum:=0;
For i:=1 to 10 do
Begin
m[i]:=Random(100);
sum:=sum+m[i];
If m[i]<m[min] then min:=i;
If m[i]>m[max] then max:=i;
Writeln(m[i]);
end;
Writeln('Ср.арифм. макс.и мин. элементов: ', (m[max]+m[min])/2);
Writeln('Ср.арифм. всех элементов: ', sum/10);
end.
Ответил pozitivnaay
0
Спасибо большое) Вы меня спасли)
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Математика,
9 лет назад
Физика,
9 лет назад
Химия,
10 лет назад