Помогите пожалуйста!!!Требуется написать программу, которая вычисляет произведение цифр заданного с клавиатуры трехзначного числа.
Например, при вводе числа 234 программа должна вывести число 24 (программа должна умножить 2х3х4), при вводе
числа 352 программа должна вывести число 30 (3х5х 2) и т.д.
Заранее спасибо!!!
Ответы на вопрос
Ответил aidaela62
3
Ответ:
Объяснение:
Скорее всего, вы имеете в виду произведение цифр трехзначного числа.
Тогда вот программа:
Program prim;
Var x, a, b,c,p: integer;
Begin
writeln('ВВедите трехзначное число');
readln(x);
a:=x div 100; {первая цифра}
b:=x mod 100 div 10; {вторая цифра}
c:=x mod 10; {третья цифра}
p:=a*b*c;
writeln('Произведение цифр=',p);
End.
Новые вопросы