Информатика, вопрос задал loligirl232 , 1 год назад

Помогите пожалуйста срочно. Напишите программу, которая по двум данным натуральным числам a и b, не превосходящим 30000, подсчитывает количество натуральных чисел, кратных 10, на отрезке [a,b] . Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1 < a < b < 30 000. Проверять входные данные на корректность не нужно. Программа должна вывести одно число: количество натуральных чисел, кратных 10, на отрезке [a,b].

Пример работы программы:

Входные данные: 7, 37

Выходные данные: 3


isteer: какой язык программирования?
LRSM: "нечетных натуральных чисел, кратных 10" - так невозможно :D
loligirl232: Я просто не то написала ,, подсчитывает количество натуральных чисел, кратных 10".

Ответы на вопрос

Ответил isteer
1

Ответ:

a = 7

b = 37

count = 0

while a != b:

  if a % 10 == 0:

       count += 1

       

   a += 1

print(count)

Объяснение:

Ответил LRSM
7

Ответ:

var a, b: smallint;

begin

   readln(a, b);

   writeln(b div 10 - a div 10);

end.

Ну или если надо с циклом и лишней переменной, а хитро и подло сделать нельзя:

var a, b, c: smallint;

begin

   readln(a, b);

   for var i := a to b do

       if (i mod 10 = 0) then c += 1;

   writeln(c);

end.

Новые вопросы