Информатика, вопрос задал vazmarina , 8 лет назад

Помогите, пожалуйста. Срочно надо! Составить программу для вычисления суммы ряда с точностью до ε = 10^-4. S = 1 + 3x + 5x^2 + 7x^3 + ... Полученный результат сравнить с точным S = (1 + x)/(1-x)^2.

Ответы на вопрос

Ответил Змей24
0
begin
  var e: double;
  var s1: double;
  var s2: double;
  var x: double;
  var step: integer;
 
  readln(x);
 
  e := 0.0001;
  s1 := 1;
  step := 3;
 
  s2 := (1 + x) / (1 - x) / (1 - x);
 
  while abs(s1 - s2) > e do begin
    s1 := s1 + (1 + 2*step)/power(x, step);
  end;
 
  writeln(s1);
  writeln(s2);
  writeln(s1 - s2);
end.

Расставь правильно скобки в условии, я исправлю решение.
Ответил vazmarina
0
условие записано верно, других скобок нет. Спасибо.
Ответил Змей24
0
Тогда неправильно и условие и решение, ведь тогда сумма ряда равна бесконечности.
Новые вопросы