Информатика, вопрос задал Katy41340 , 9 лет назад

Помогите пожалуйста! Срочно надо написать программу в паскале. Задание: Введите три трёхзначных числа. Найти разность между наибольшим м наименьшим. Заранее спасибо!

Ответы на вопрос

Ответил HRAshton
0
begin
  var a, b, c: single;
  readln(a, b, c);
  writeln(max(a, max(b, c)) - min(a, min(b, c)));
end.

Позязя, расширеннее...
begin
  var a, b, c, d, e: single;
  readln(a, b, c);
  if (a < b) then
    d := a
  else
    d := b;
  if (c < d) then
    d := c;
  if (a > b) then
    e := a
  else
    e := b;
  if (c > e) then
    e := c;
    writeln(e - d);
end.
Ответил Katy41340
0
развёрнуто
Новые вопросы