Информатика, вопрос задал Тальони , 2 года назад

Помогите пожалуйста,срочно!

1. Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).Сделайте три варианты программ,используя операторы цикла While,Repeat и For.

2. Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате сообщит,сколько среди введенных чисел четных и сколько нечетных.

Заранее спасибо!

Ответы на вопрос

Ответил kordark
16
Тут абзацы не отображаются, напишу в комментах

kordark: 1. while.
const N:=10;
var x,i: integer;
s: real;
begin
i:=0;
s:=0;
writeln("Введите числа");
while (i<N) do
readln(x);
s:=s+x;
i:=i+1;
end;
writeln(s/N);
end.
kordark: 2. const N:=10;
var i,x,chet,nechet: integer;
begin
chet:=0;
nechet:=0;
writeln("Введите ", N, " чисел.");
for i:=1 to N do begin
readln(x);
if x mod 2 &lt;&gt; 0 then
nechet:=nechet+1
else
chet:=chet+1;
end;
writeln("Чётных чисел: ", chet);
writeln("Нечетных чисел: ", nechet);
end.
Тальони: Спасибо огромное!
Новые вопросы