Информатика, вопрос задал vanish69 , 9 лет назад

помогите пожалуйста!
составьте программу заполнения массива а [1...10] числами фибоначчи. в последовательности фибоначчи значения первых двух элементов равны 1, а значение каждого последующего элемента, начиная с третьего, равно сумме двух предыдущих.
индексы элементов 1 2 3 4 5 6 7 8 9 10
значение элемента 1 1 2 3 5 8 13 21 34 55

Ответы на вопрос

Ответил kage1998
0
program gt;
var a:array[1..10]of integer;
i:integer;
begin
a[1]:=1;a[2]:=1;
write(a[1],' ',a[2],' ');
for i:=3 to 10 do
begin
a[i]:=a[i-2]+a[i-1];
write(a[i],' ');
end;
end.
Ответил vanish69
0
спасибо большое! ^^
Новые вопросы