Информатика, вопрос задал aidkit18 , 8 лет назад

ПОМОГИТЕ!! пожалуйста!
составьте программу подсчета числа элемента одновременного массива, превосходящих среднее арифметическое элементов данного массива.

Ответы на вопрос

Ответил Brendell
0
Программа написана на PascalABC.NET

// Ниже код:

program element;
var a: array[1..1000] of real;    i, j, c: integer;    b: real;    begin  writeln('Введите число элементов: ');  read(j);    for i:= 1 to j do    begin      read(a[i]);      b:= b + a[i];    end;    b:= b / j;    for i:= 1 to j do    if a[i] > b then inc(c);    writeln;  write('Ответ: ', c);end.
Приложения:
Ответил Brendell
0
Не знаю почему форматирование сбилось
Ответил FreeProgrammer
0
при копировании и вставке в окно редактор не воспринимает Enter из файла. Приходится уже в окне редактировать, нажимая Alt+Enter. Наступала на эти "грабли" несколько раз, пока методом проб и ошибок не получила нужный вид)))
Новые вопросы