Помогите пожалуйста)
Составьте программу,которая заполняет массив a[1..8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.
Ответы на вопрос
Ответил Bogdanshik5
0
var a:array[1..8]of integer;
i,k,s:integer;
begin
for i:=1 to 8 do
begin
a[i]:=random(10)+1;
write(a[i],' ');
if a[i] mod 2=0 then k:=k+1
else s:=s+a[i];
end;
writeln;
writeln('kol-vo chet elem:',k,' summa nechet:',s);
end.
i,k,s:integer;
begin
for i:=1 to 8 do
begin
a[i]:=random(10)+1;
write(a[i],' ');
if a[i] mod 2=0 then k:=k+1
else s:=s+a[i];
end;
writeln;
writeln('kol-vo chet elem:',k,' summa nechet:',s);
end.
Ответил Bogdanshik5
0
тогда будет находить сумму чётных
Ответил Bogdanshik5
0
и количество нечётных
Ответил Bogdanshik5
0
во всяком случае в условии твоём то ""выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями"".
Ответил Bogdanshik5
0
да ладно уж
Ответил Bogdanshik5
0
сделай лучшим ответом плз
Новые вопросы
Биология,
2 года назад
Английский язык,
2 года назад
Химия,
9 лет назад
Алгебра,
9 лет назад
Алгебра,
10 лет назад