Информатика, вопрос задал FutureStudent2 , 9 лет назад

Помогите пожалуйста!!! Составить программы Pasсal

1) Даны величины двух углов треугольника в градусах.
Составьте программу, которая определяет, существует ли такой треугольник. Если да, то будет ли он остроугольным, прямоугольным или тупоугольным.

2)На плоскости XOY заданы своими координатами три не совпадающие точки А(X1, Y1),
B(X2, Y2) , и C(X3 , Y3).
Составить программу, которая определяет, где расположена точка C ;
выше, ниже или на отрезке АВ.

Ответы на вопрос

Ответил walleri18
0
Первая задача
program firstProgram
var ug1, ug2: real;
begin
write("Введите первый угол: ");

read(ug1);

write("Введите второй угол: ");

read(ug2);

if ((ug1 + ug2) < 180)
begin

if ((ug1 > 90) or (ug2 > 90)) write("Треугольник тупоугольный");

else if ((ug1 = 90) or (ug2 = 90)) write("Треугольник прямоугольный");

else write("Треугольник остроугольный");

end
end
Новые вопросы