Информатика, вопрос задал mexawa9158 , 7 лет назад

Помогите пожалуйста!!!

Составить программу в Паскале для обработки массива из 15 чисел Х = (0; 1,25; –371; 0,5; –0,1; 1,2; –5; –172,3; 19783; –2,7; 43,51; 0; –0,02; 14,5; 123,7). Найти наименьший элемент и его номер. В отчет включить программный код и результат работы программы.

Ответы на вопрос

Ответил kukolev
0

Ответ:

program Project1;

const

 n = 15;

var

 c: array[1..n] of real = (0, 1.25, -371, 0.5, -0.1, 1.2, -5, -172.3, 19783, -2.7, 43.51, 0, -0.02, 14.5, 123.7);

 // Переменная для хранения массива.

 i: integer; // Вспомогательная переменная для организации цикла.

 minelem: real; // Переменная для хранения значения элемента с минимальным значением.

 indmin: integer; // Переменная для хранения значения индекса минимального элемента.

 

begin

 writeln('Исходный массив:');

 for i:= 1 to n do      // Вывод массива в консоль.

   begin

     write(c[i]:9:2);

     if i mod 8 = 0 then

       writeln;

   end;

 writeln;

 minelem:= c[1];

 indmin:= 1;

 for i:= 2 to n do

   if c[i] < minelem then // Условие для нахождения элемента с минимальным значением.

     begin

       minelem:= c[i];

       indmin:= i; // Индекс элемента с минимальным значением.

     end;

 writeln('Минимальный элемент массива находится на ',indmin,' месте и равен ',minelem:0:2);

 Readln;

end.

Объяснение:

     В принципе я указал комментарии к некоторым действиям, так что должно быть понятно(комментарии потом лучше стереть). В отчет можешь сделать скриншот уже с результатом работы программы (мы так обычно делаем). Если остались вопросы пиши в комментарии.

Ответил kukolev
0
Не за что!!
Ответил BobbyFresnel
0

===== PascalABC.NET =====

begin

 var x := Arr(0.0, 1.25, -371.0, 0.5, -0.1, 1.2, -5.0, -172.3,

     19783.0, -2.7, 43.51, 0.0, -0.02, 14.5, 123.7);

 var im := x.IndexMin;

 Write('Минимальный элемент номер ', im + 1, ' равен ', x[im])

end.

Приложения:
Новые вопросы